e220 openwrt kamikaze wgt634u
installed new firmware
http://www.a1.net/CDA/navigation/pp4_frame/0,6194,50158-51220-51216-500626-html-de,00.html
gives 7.2mbs :-) if your network supports it....
modified /etc/init.d/S95done
sleep 30
/etc/init.d/network restart
/usr/sbin/dropbear -s -p 443
edit firewall.user to add
iptables -t nat -A prerouting_wan -p tcp --dport 443 -j ACCEPT
iptables -A input_wan -p tcp --dport 443 -j ACCEPT
change order of modules make sure storage starts before serial
ls /etc/modules.d
root@OpenWrt:~# ls -l /etc/modules.d/
-rw-r----- 1 root root 9 May 12 12:15 20-scsi-core
-rw-r--r-- 1 root root 35 May 12 12:17 20-switch
-rw-r----- 1 root root 8 May 12 12:25 20-usb-core
-rw-r----- 1 root root 37 May 12 12:25 30-ppp
-rw-r--r-- 1 root root 86 May 12 12:25 40-ipt-nathelper
-rw-r----- 1 root root 7 May 12 12:15 40-scsi-core
-rw-r--r-- 1 root root 115 May 12 12:08 50-madwifi
-rw-r--r-- 1 root root 9 May 12 12:25 50-usb-ohci
-rw-r--r-- 1 root root 9 May 12 12:25 50-usb2
-rw-r----- 1 root root 28 Jan 1 2000 55-usb-storage
-rw-r----- 1 root root 52 Jan 1 2000 60-usb-serial
modified usb serial
root@OpenWrt:~# cat /etc/modules.d/60-usb-serial
usbserial vendor=0x12d1 product=0x1003 maxSize=4096
edit /etc/config/network to add 3g
#### WAN configuration
config interface wan
option ifname "ppp0"
option ifname "ppp0"
option device "/dev/ttyUSB0"
option proto "3g"
option apn "open.internet"
option service "hsdpa"
http://www.a1.net/CDA/navigation/pp4_frame/0,6194,50158-51220-51216-500626-html-de,00.html
gives 7.2mbs :-) if your network supports it....
modified /etc/init.d/S95done
sleep 30
/etc/init.d/network restart
/usr/sbin/dropbear -s -p 443
edit firewall.user to add
iptables -t nat -A prerouting_wan -p tcp --dport 443 -j ACCEPT
iptables -A input_wan -p tcp --dport 443 -j ACCEPT
change order of modules make sure storage starts before serial
ls /etc/modules.d
root@OpenWrt:~# ls -l /etc/modules.d/
-rw-r----- 1 root root 9 May 12 12:15 20-scsi-core
-rw-r--r-- 1 root root 35 May 12 12:17 20-switch
-rw-r----- 1 root root 8 May 12 12:25 20-usb-core
-rw-r----- 1 root root 37 May 12 12:25 30-ppp
-rw-r--r-- 1 root root 86 May 12 12:25 40-ipt-nathelper
-rw-r----- 1 root root 7 May 12 12:15 40-scsi-core
-rw-r--r-- 1 root root 115 May 12 12:08 50-madwifi
-rw-r--r-- 1 root root 9 May 12 12:25 50-usb-ohci
-rw-r--r-- 1 root root 9 May 12 12:25 50-usb2
-rw-r----- 1 root root 28 Jan 1 2000 55-usb-storage
-rw-r----- 1 root root 52 Jan 1 2000 60-usb-serial
modified usb serial
root@OpenWrt:~# cat /etc/modules.d/60-usb-serial
usbserial vendor=0x12d1 product=0x1003 maxSize=4096
edit /etc/config/network to add 3g
#### WAN configuration
config interface wan
option ifname "ppp0"
option ifname "ppp0"
option device "/dev/ttyUSB0"
option proto "3g"
option apn "open.internet"
option service "hsdpa"
Comments
What openwrt version are you using?
What packages have you installed to make this work?
Thanks
I built with relevant support for usb components and usb serial and comgt package (which allows configuring 3g in network scripts etc.)
my post assumes some basic linux knowledge too.
I will point out that I have an e270 and e220, and both intermittantly disconnect and i need to modprobe usbserial again and restart network script (or reboot).
I am pretty convinced this is a bug in the modems firmware, as I have tried on several different linux distros and got disconnects (with different messages ) on all of them, though newer distros like heron seem to recover better.
If I was doing this again, i would get a 3g phone like the sony k800i or newer as it supports usb ethernet , i.e. you connect the usb cable and openwrt sees an ethernet, does a dhcp request and has an ip on the internet, no ppp scripting etc.